您的位置 首页 程序化交易

同花顺罗麦精准线主图代码源码[同花顺公式]

相关标签: expma金叉选股公式 、 通达信expma指标公式 、 expma四条线指标详解 、 expma指标的参数设置 、 通达信怎么添加expma 、 expma主图指标公…

相关标签: expma金叉选股公式 、 通达信expma指标公式 、 expma四条线指标详解 、 expma指标的参数设置 、 通达信怎么添加expma 、 expma主图指标公式 、
原理解析:
输出UB:BOLL+2*收盘价的20日估算标准差,线宽为2
TY赋值:最低价
A1赋值:10日前的TY=2*10+1日内TY的最高值
B1赋值:A1的10日过滤
C1赋值:若B1则将最近10+1周期置为1
HD赋值:C1的10日过滤
A2赋值:10日前的TY=2*10+1日内TY的最低值
B2赋值:A2的10日过滤
C2赋值:若B2则将最近10+1周期置为1
LD赋值:C2的10日过滤
输出前期低位:上次LD距今天数日前的最低价,COLOR00FF00,POINTDOT
当满足条件最低价时,在前期低位和前期低位位置之间画柱状线,宽度为8,0不为0则画空心柱.,画红色
TZ赋值:最高价
A3赋值:10日前的TY=2*10+1日内TY的最高值
B3赋值:A1的10日过滤
C3赋值:若B1则将最近10+1周期置为1
MD赋值:C1的10日过滤
A4赋值:10日前的TY=2*10+1日内TY的最低值
B4赋值:A2的10日过滤
C4赋值:若B2则将最近10+1周期置为1
ND赋值:C2的10日过滤
输出前期高位:上次MD距今天数日前的最高价,COLOR00FF00,POINTDOT
当满足条件最高价时,在前期高位和前期高位位置之间画柱状线,宽度为8,0不为0则画空心柱.,画绿色
TA赋值:(最高价-最低价)和1日前的收盘价-最高价的绝对值的较大值和1日前的收盘价-最低价的绝对值的较大值
ATR赋值:TA的13日指数移动平均
VAR81赋值:1日前的收盘价-1日前的ATR
输出破了出:13日内VAR81的最高值,画黄色
当满足条件是否最后一个周期时,在破了出位置书写文字,画黄色
V2V赋值:成交量(手)/1日前的成交量(手)>=1.9 AND 收盘价>1日前的收盘价
当满足条件V2V时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画黄色
当满足条件V2V时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0033FF
当满足条件V2V时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0077FF
当满足条件V2V时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00BBFF
当满足条件V2V时,在开盘价和收盘价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR00FFFF
V2VE赋值:成交量(手)/1日前的成交量(手)>=1.9 AND 收阴线
当满足条件V2VE时,在开盘价和收盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,COLORFFFF00
当满足条件V2VE时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR005500
当满足条件V2VE时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR009900
当满足条件V2VE时,在开盘价和收盘价位置之间画柱状线,宽度为0.6,0不为0则画空心柱.,COLOR00BB00
当满足条件V2VE时,在开盘价和收盘价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR00FF00
ZT赋值:收盘价/1日前的收盘价>1.097
当满足条件ZT时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画洋红色
DT赋值:1日前的收盘价/收盘价>1.097
当满足条件DT时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF3300
当满足条件DT时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFF7700
当满足条件DT时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFFAA00
当满足条件DT时,在开盘价和收盘价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLORFFFF00
源码:
UB:BOLL+2*STD(CLOSE,20),LINETHICK2; TY:=L; A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10); A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10); 前期低位:REF(L,BARSLAST(LD)),COLOR00FF00,POINTDOT; STICKLINE(L,前期低位,前期低位,8,0),colorred; TZ:=H; A3:=REF(TY,10)=HHV(TY,2*10+1); B3:=FILTER(A1,10); C3:=BACKSET(B1,10+1); MD:=FILTER(C1,10); A4:=REF(TY,10)=LLV(TY,2*10+1); B4:=FILTER(A2,10); C4:=BACKSET(B2,10+1); ND:=FILTER(C2,10); 前期高位:REF(H,BARSLAST(MD)),COLOR00FF00,POINTDOT; STICKLINE(H,前期高位,前期高位,8,0),colorgreen; TA:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW)); ATR:=EMA(TA,13); VAR81:=REF(CLOSE,1)-REF(ATR,1); 破了出:HHV(VAR81,13),coloryellow; DRAWTEXT(ISLASTBAR,破了出,’破了出’),coloryellow; V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1); STICKLINE(V2V,H,L,0,0),coloryellow; STICKLINE(V2V,O,C,3,0),COLOR0033FF; STICKLINE(V2V,O,C,2,0),COLOR0077FF; STICKLINE(V2V,O,C,1,0),COLOR00BBFF; STICKLINE(V2V,O,C,0.1,0),COLOR00FFFF; V2VE:=V/REF(V,1)>=1.9 AND C<O; STICKLINE(V2VE,O,C,3,1),COLORFFFF00; STICKLINE(V2VE,O,C,2,0),COLOR005500; STICKLINE(V2VE,O,C,1,0),COLOR009900; STICKLINE(V2VE,O,C,0.6,0),COLOR00BB00; STICKLINE(V2VE,O,C,0.1,0),COLOR00FF00; ZT:=C/REF(C,1)>1.097; STICKLINE(ZT,O,C,3,0),colormagenta; DT:=REF(C,1)/C>1.097; STICKLINE(DT,O,C,3,0),COLORFF3300; STICKLINE(DT,O,C,2,0),COLORFF7700; STICKLINE(DT,O,C,1,0),COLORFFAA00; STICKLINE(DT,O,C,0.1,0),COLORFFFF00;{来源:www.cxh99.com 程序化交易}
公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程】
本文来自网络,不代表隽焱网立场,转载请注明出处:https://www.780008.com/future/%e7%a8%8b%e5%ba%8f%e5%8c%96%e4%ba%a4%e6%98%93/55419.html

作者: junyanwang

为您推荐

发表评论

联系我们

联系我们

在线咨询: QQ交谈

邮箱: 2265783423@qq.com

工作时间:周一至周五,9:00-17:30,节假日休息

关注微信
微信扫一扫关注我们

微信扫一扫关注我们

返回顶部